Selection Problem with DATEX Tool

Submitted by Joerg Freudenstein on Monday, 26 August, 2013 - 11:09
Issue ID
132
Component
Tool
Category
Bug report
Priority
Normal
Assigned
Status
Closed
Source
Website
Description

Using a selection file (.sel) which produced a proper schema before, now some base class elements are not selected in the navigation tree anymore. As those elements are mandatory, it is not possible to change their state, i.e. to select them again. Problem 1 is: Why did those elements disappear in the selection? Problem 2 is: How to reselect those elements in this situation? The problem does not appear without using a selection file, i.e. just reading the XMI-file and selecting elements works fine in this context. The problem is quite specific; details (especially the elements and the seletion file in question) have been communicated to Jonas Jäderberg.

Found Version
{"changeLogs":[{"date":1528372888362,"componentOLD":"- Select a value -","component":"Tool","categoryOLD":"- Select a value -","category":"Bug report","priorityOLD":"- None -","priority":"Normal","assignedOLD":"","assigned":"jaderberg (22)","statusOLD":"- None -","status":"Closed"},{"date":1537269013209}]}

Posted by jaderberg on January 26, 2025 Permalink

Problem1: They disappear because the selection file says that they be so.
Problem2: We haven no way, but It should not be possible..

If I take the current tool and selects an equal profile and save the selection these classes and attributes are marked as selected. So, there must be something wrong with the selection file or there is an earlier bug that has been corrected that fixed the problem.